XPS duplicate ghost

General discussion and questions about XNALara go here.

Moderators: Runa, ObscureMemories, Love2Raid

Posts: 51
Joined: Mon Sep 30, 2013 11:42 pm
Custom Rank: Soul Calibur Fan

XPS duplicate ghost

Postby WuHT » Thu May 11, 2017 10:19 pm

I wanted to try to convert yoshimitsu's MDL file to a XPS file because MDL files apparantly don't have facial rigs and luckily Yoshi has a wooden face which doesn't need posing.
I'm stuck however.

I don't know how to categorize the issue i'm having so i'll try to describe it:

http://imgur.com/a/llS7i is the image of the step where I'm stuck.

I have one model (blue) that is stuck in the ground and one white model that is standing on the group. Neither of theses can be manipulated by any of the bones, except for the Koshi_jnt (the root hip bone I suspect) which would only manipulate the blue model. The blue model also superimposes another white model which is the one where all the bones are attached.

XPS is 11.8
Blender is 2.78
Noesis is 4.25

The mediafire link for what I've done up to is here if anyone is confused by what i'm describing: http://www.mediafire.com/file/rybkqhurg ... oshi+1p.7z

Some of my observations
1) I used the cannonfodder studiocompiler to decompile the original MDL file. It gives me several SMD files (various parts of Yoshitmisu) including a ragdoll.smd (which I suspect is important) and a "unknownmodelname.smd" which I suspect is less so.
2) In blender I imported the mdldecompiler.gc file rather than the individual smd files together. I'm guessing that opens all the associated SMD files at once. I hit A to select everything and then I export to xps.xps and try to pop it in xps and see what I get.
3) This particular model has a mask-open and a mask-close SMD. Is the 2 different states a reason why I'm having this superimposition error or completely unrelated ?
4) Basically i'm using Blender strictly to convert from SMD file to XPS and trying to avoid any manipulation. I may learn to add a pelvis bone in the future but I want to at least get a working XPS model
---
I appreciate all help provided

Posts: 51
Joined: Mon Sep 30, 2013 11:42 pm
Custom Rank: Soul Calibur Fan

Re: XPS duplicate ghost

Postby WuHT » Fri Jun 02, 2017 5:20 am

Well my experience was this:

Just use the Ctrl-T material editor and start attaching the textures. Sometimes "unknown" is the referenced texture and this caused a lot of the glitches seen in Xps. When I attached the textures it sort of corrected itself.

While not the most satisfactory solution I can't argue with the outcome :D I saw a couple of downloads so I guess thanks to the stranger(s) who gave it a shot.

I figured I might attempt to answer this (despite me bringing it up) to provide some closure and maybe some curious person down the road may have encountered this problem and seen that it was actually addressed.
---
I appreciate all help provided

Return to General

Who is online

Users browsing this forum: Bing [Bot] and 1 guest